안드로이드 스튜디오는 Java6가 설치돼있어야 동작한다. Java6가 설치돼있지 않으면 다음과 같은 메세지가 나타나고 실행이 안 된다.




현재 java의 최신버전인 java8(1.8)이 설치돼있어도 실행되지 않는다. 안드로이드 스튜디오의 환경 설정 파일을 조금 수정하면 java8에서 동작한다. 다음 그림과 같이 안드로이드 스튜디오 실행 파일에서 마우스 오른쪽 버튼을 누르고 패키지 내용 보기를 선택한다.



패키지 내부는 다음과 같은 폴더 구조다. Info.plist를 열어서 java 버전을 변경해야 한다.



JVMOptions 항목의 JVMVersion 을 다음과 같이 1.8*로 변경한다. 




이제 java8에 동작하는 안드로이드 스튜디오를 실행할 수 있다.

반응형

+ Recent posts